ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //ПарСумма - сумма, число
      

//коп - Выводится всегда
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп."
КонецФункции

//Если копеек нет, то они и не выводятся
Функция РубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат " "
КонецЕсли;
коп = (ПарСумма-Цел(ПарСумма))* 100;
Возврат ""+Цел(ПарСумма)+" руб. "+?(коп>0, Формат(коп,"ЧЦ=2; ЧВН=")+" коп.","")
КонецФункции


//Пример обращения
Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщить(глРубКоп(ИтогоСумм)); //К примеру ИтогоСумм=875.05; - Результат 875 руб. 05 коп.
КонецПроцедуры



Код 1C v 7.x
 
      
// ПарСумма - сумма, число
//
// Возвращаемое значение:
// строка в виде: "ррр руб. кк коп."
//
// Описание:
// Преобразует переданную сумму в строку вида "ррр руб. кк коп."
//
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"Ч(0)2")+" коп."
КонецФункции

//Пример обращения
ИтогоСумм=875.05;
Сообщить(глРубКоп(ИтогоСумм)); // 875 руб. 05 коп.



Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.