Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Функция предназначена для получения имени элемента перечисления по значению

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
// Предназначена для получения имени элемента перечисления по значению.
//
// Параметры:
// Элемент перечисления.
//
// Возвращаемое значение:
// Строка - имя элемента перечисления в метаданных.
//
Функция ПолучитьИмяЭлементаПеречисленияПоЗначению(ЗначениеПеречисления) Экспорт

ИмяЭлемента = Строка(ЗначениеПеречисления);
Для каждого ЭлементПеречисления Из Метаданные.Перечисления[ЗначениеПеречисления.Метаданные().Имя].ЗначенияПеречисления Цикл
Если ЭлементПеречисления.Синоним = Строка(ЗначениеПеречисления) Тогда
ИмяЭлемента = ЭлементПеречисления.Имя;
Прервать;
КонецЕсли;
КонецЦикла;

Возврат ИмяЭлемента;

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.