ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
//Функции преобразуют время из представления в виде строки в число и обратно
//
// Параметры:
// Время - Строка - Строковое представление времени 12:51
//
// Возвращаемое значение:
// Время - Число 5.2 - Время в виде числа
Функция ВремяСтрокаВЧисло(Время) Экспорт

Поз = Найти(Время,":");
Если НЕ Поз тогда
Возврат 0;
КонецЕсли;
ЦелЧасть = Число(Лев(Время,Поз-1));
ДробЧасть = Число(Сред(Время,Поз+1,6)) / 60;
Возврат ЦелЧасть + ДробЧасть;

КонецФункции

// Преобразует время из числового представления в строкове
Функция ВремяЧислоВСтрока(Время) Экспорт

ЦелЧасть = Цел(Время);
ДробЧасть = (Время - ЦелЧасть) * 60;
Возврат Строка(ЦелЧасть) + ":" + Строка(Окр(ДробЧасть,0));

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.