Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Функции преобразуют время из представления в виде строки в число и обратно

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
//Функции преобразуют время из представления в виде строки в число и обратно
//
// Параметры:
// Время - Строка - Строковое представление времени 12:51
//
// Возвращаемое значение:
// Время - Число 5.2 - Время в виде числа
Функция ВремяСтрокаВЧисло(Время) Экспорт

Поз = Найти(Время,":");
Если НЕ Поз тогда
Возврат 0;
КонецЕсли;
ЦелЧасть = Число(Лев(Время,Поз-1));
ДробЧасть = Число(Сред(Время,Поз+1,6)) / 60;
Возврат ЦелЧасть + ДробЧасть;

КонецФункции

// Преобразует время из числового представления в строкове
Функция ВремяЧислоВСтрока(Время) Экспорт

ЦелЧасть = Цел(Время);
ДробЧасть = (Время - ЦелЧасть) * 60;
Возврат Строка(ЦелЧасть) + ":" + Строка(Окр(ДробЧасть,0));

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.