Простите за всплывающее окно, но мы обязаны предупредить, что наш сайт использует куки-файлы. Это помогает нам быть лучше и полезнее для вас.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Функции преобразуют табличный документ (ТД) в строку и обратно

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Функция ТабличныйДокументВСтроку(ТД) Экспорт
      
Попытка
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ТД.Записать(ИмяФайла);
ДД=Новый ДвоичныеДанные(ИмяФайла);
Стр=Base64Строка(ДД);
ДД=Неопределено;
УдалитьФайлы(ИмяФайла);
Возврат Стр;
Исключение
Возврат Неопределено;
КонецПопытки;
КонецФункции

Функция ТабличныйДокументИЗСтроки(ТД, Стр) Экспорт
Если СокрЛП(Стр)="" Тогда
Возврат ложь;
КонецЕсли;
Попытка
ДД=Base64Значение(Стр);
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ДД.Записать(ИмяФайла);
ДД=Неопределено;
ТД.Прочитать(ИмяФайла);
УдалитьФайлы(ИмяФайла);
Возврат истина;
Исключение
Возврат ложь;
КонецПопытки;
КонецФункции
Поделиться в соц. сетях


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.