Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
//Реквизит "Листы" - неопределённого типа
//Реквизит "Файл" - строковой реквизит, в котором хранится путь к excel-файлу

Процедура ЗаполнитьЛисты()

ЭлементыФормы.Листы.СписокВыбора.Очистить();
Таблица = ПолучитьCOMОбъект(Файл);

Для Н = 1 По Таблица.Sheets.Count Цикл
ТекущийЛист = Строка(Таблица.Sheets(Н).Index) + ". " + Таблица.Sheets(Н).Name;
ЭлементыФормы.Листы.СписокВыбора.Добавить(ТекущийЛист);
КонецЦикла;
ЭлементыФормы.Листы.Значение = ТекущийЛист;

КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

Если ЭлементыФормы.Листы.Значение = "" Тогда
Предупреждение("Выберите лист", 5);
Возврат;
КонецЕсли;

Таблица = ПолучитьCOMОбъект(Файл);
Индекс = Число(Сред(ЭлементыФормы.Листы.Значение, 1, Найти(ЭлементыФормы.Листы.Значение, ". ") - 1));//извлекаем порядковый номер из текущего значения списка выбора
Лист = Таблица.Sheets(Индекс);//получаем лист по порядковому номеру

//теперь обращаемся к значениям в ячейках по своему усмотрению

Строка = 1;
Столбец = 4;

КодНоменклатуры = Лист.Cells(Строка, Столбец).Value);
Номенклатура = Лист.Cells(Строка, Столбец + 1).Text);

КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.