ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
//Реквизит "Листы" - неопределённого типа
//Реквизит "Файл" - строковой реквизит, в котором хранится путь к excel-файлу

Процедура ЗаполнитьЛисты()

ЭлементыФормы.Листы.СписокВыбора.Очистить();
Таблица = ПолучитьCOMОбъект(Файл);

Для Н = 1 По Таблица.Sheets.Count Цикл
ТекущийЛист = Строка(Таблица.Sheets(Н).Index) + ". " + Таблица.Sheets(Н).Name;
ЭлементыФормы.Листы.СписокВыбора.Добавить(ТекущийЛист);
КонецЦикла;
ЭлементыФормы.Листы.Значение = ТекущийЛист;

КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

Если ЭлементыФормы.Листы.Значение = "" Тогда
Предупреждение("Выберите лист", 5);
Возврат;
КонецЕсли;

Таблица = ПолучитьCOMОбъект(Файл);
Индекс = Число(Сред(ЭлементыФормы.Листы.Значение, 1, Найти(ЭлементыФормы.Листы.Значение, ". ") - 1));//извлекаем порядковый номер из текущего значения списка выбора
Лист = Таблица.Sheets(Индекс);//получаем лист по порядковому номеру

//теперь обращаемся к значениям в ячейках по своему усмотрению

Строка = 1;
Столбец = 4;

КодНоменклатуры = Лист.Cells(Строка, Столбец).Value);
Номенклатура = Лист.Cells(Строка, Столбец + 1).Text);

КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.