Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

1с: В 1С:Зарплата и Кадры 7.7 релиз 284. При открытии Формы Т-2 вываливается ошибка, если у сотрудника был Отпуск по уходу за ребенком" ..."

Проконсультироваться
со специалистом 1С

Консультироваться

<B>Ответ 1с:</B><BR><p>Для исправления данной ошибки обратитесь к специалисту по конфигурированию 1С:Предприятия 7.7.<br /> <br /> кусок кода<br /> <br /> Если ДокОтпуск.ДокОснование.Вид() = "ПриказОбУвольнении" Тогда<br /> ТабОтп.ПриказПоОтпуску = ДокОтпуск.ДокОснование;<br /> Иначе<br /> ТабОтп.ПриказПоОтпуску = ПолучитьПриказПоОтпуску(ДокОтпуск.ТекущийДокумент());<br /> КонецЕсли;<br /> <br /> заменить на<br /> <br /> ТабОтп.ПриказПоОтпуску = ПолучитьПриказПоОтпуску(ДокОтпуск.ТекущийДокумент());<br /> <br /> как и было в релизе 283. А в процедуре ПолучитьПриказПоОтпуску() после<br /> <br /> Если ДокНачОтп.Вид() = "ОтпускПоУходуЗаРебенком" Тогда<br /> ДокументОснование = ДокНачОтп.ДокументОснование;<br /> Иначе<br /> ДокументОснование = ДокНачОтп.ДокОснование;<br /> КонецЕсли;<br /> <br /> добавить<br /> <br /> Если ДокументОснование.Вид() = "ПриказОбУвольнении" Тогда<br /> Возврат ДокументОснование;<br /> КонецЕсли;</p>


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.